LibreOfficeで動作するLOGOプログラミング言語

https://www.catch.jp:443/wiki/index.php?Programing%2FLibreLogo

Programing>LibreLogo

CC BY 2.0

実際に使ってみる

現在配布されているLibreOffice4.0.1以降には、Logo機能が標準搭載されています。

準備

  1. LibreOfficeの4.0.1以降を入手してインストール > LibreOffice : 自由なオープンソースのオフィススイート
  2. LibreOfficeのWriterを起動する
  3. 「表示」-「ツールバー」-「Logo」

これで、Logoプログラムを制御するツールバーが表示されました。

プログラムを実行する

Writerの画面に、カメ(タートル)でサンカクをかいてみよう。

  1. Writerのテキストとして、コードを入力する
  2. Logoツールバーの実行ボタンをクリックする

以下は、とっても簡単なサンプルコード。

REPEAT 3 [
 FORWARD 50
 LEFT 120
]
librelogo.png

LibreLOGOを日本語化する

コマンドを日本語にする

  1. 「ツール」-「オプション」
  2. 「オプション」ダイアログの「言語設定」-「言語」を選択
  3. 「ドキュメントの標準言語」
    • 「西欧諸言語」を「なし」
    • 「アジア諸言語」を「標準 - 日本語」
    • 「現在のドキュメントのみに適用」を「オン」
  4. 「OK」ボタン

これで、設定完了。

次のようにコードを書くと、同じように実行できますね。

くりかえす 3 [
 すすむ 50
 左 120
]
librelogo_ja.png

使い方

参考資料


  トップ   差分 バックアップ リロード   一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
添付ファイル: filelibrelogo_ja.png 1177件 [詳細] filelibrelogo.png 1332件 [詳細]
Last-modified: 2013-04-06 (土) 21:58:33 (2112d)